[转载]龙头战法常用辅助指标公式汇总_玉龙腾飞_新浪博客

首页 > 教育 > 正文 2021-09-11

发表自话题:通达信追板打板专用指标公式



有朋友经常询问这个公式那个公式的代码,实际复盘中用到的公式都在论坛中断断续续的分享过,现在为了方便大家的查找,做一个公式汇总。几点说明如下:

 

1、正确对待公式,不要有极端看法。不要迷信公式,指标仅仅是辅助,真正做决策的是自己的大脑;不要排斥公式,如中正式步枪替代汉阳造,极大地提高了杀敌效率,是科技的进步。

 

2、尝试自己编写或者修改公式。每个人的操作系统不一样,需要辅助的指标公式应该是有差异的,根据自己的操作习惯,适度调整公式,匹配自己的模式,会更高效。

 

3、对于实在搞不定的朋友,索取外“包”服务,可以提供远程安装指导。但要记得加油或者捧场打点小费哦,通过发站内信求助。


 指标公式汇总如下(通达信版本):

     

     一、主图、副图指标公式:

     

 

     1、主图:


 EMA5:EMA(C,5),COLORWHITE;
       EMA13:EMA(C,13),COLORYELLOW;
       EMA34:EMA(C,34),COLORF00FF0;
       EMA55:EMA(C,55),COLORGREEN;
       AA05:=EMA5;
       角度1:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
       AA051:=EMA13;
       角度2:=ATAN((AA051/REF(AA051,1)-1)*100)*180/3.1416;
       AA052:=EMA34;
       角度3:=ATAN((AA052/REF(AA052,1)-1)*100)*180/3.1416;
       
       IF(角度1>60,EMA5,DRAWNULL),COLORRED,LINETHICK1;
       IF(角度2>45,EMA13,DRAWNULL),COLORRED,LINETHICK1;
       IF(角度3>30,EMA34,DRAWNULL),COLORRED,LINETHICK1;
       
       
       涨停:=IF(REF(C,1)*1.1-CEMA(EMA(EMA(S1,2),2),2);
       S3:= C/REF(C,1)>1.05;
       
       DRAWTEXT(BETWEEN(DMI.PDI,37,45) AND S3  AND  S2,L*0.98,‘↖亮剑‘),COLORYELLOW;
       
       DRAWTEXT(BETWEEN(DMI.PDI,45,50)AND  S3  AND S2,L*0.98,‘↖小牛‘),COLORYELLOW;
       
       DRAWTEXT(BETWEEN(DMI.PDI,50,53)AND  S3  AND S2,L*0.98,‘↖大牛‘),COLORYELLOW;
       
       DRAWTEXT(DMI.PDI>53 AND  S3 AND  S2, L*0.98,‘↖疯牛‘),COLORYELLOW;
       
       DRAWTEXT(REF(DMI.ADX,1)>50 AND CROSS(REF(DMI.ADX,1),DMI.ADX),H*1.01,‘↙变盘‘),COLORMAGENTA;
       
       DRAWTEXT(REF(DMI.PDI,1)>53 AND CROSS(REF(DMI.PDI,1),DMI.PDI),H*0.98,‘←大顶‘),COLORGREEN;
       
       DRAWTEXT(REF(DMI.PDI,1)1),VVOL,0,-1,-1),COLOR00C0C0;
       VOLUME:VOL,VOLSTICK;
       日收盘:=C#DAY;日最高:=H#DAY;日最低:=L#DAY;
       涨停:=IF(REF(日收盘,1)*1.095-日收盘=(10-0.01*100/CE3),1,0) AND 日收盘=日最低;
       STICKLINE(涨停,0,V,2.5,0),COLORYELLOW;{如果太大或太小,调整3的数值大小就可以};
       
       AA:=VOL>REF(V,1)*2.0;
       STICKLINE(AA,0,V,1.25,0),COLORMAGENTA;
       
       二、盘中常用预警公式:



 每一小段是一个公式,上面是程式,下面是公式名称。
       
       C>=REF(C,1)*1.05;
       ↑涨5点
       
       CREF(HHV(H,0),1);
       ↑历史新高
       
       C>=HHV(H,20);  
       ↑20日新高
       
       TY:=C;
       A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
       A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
       前期高位:=REF(C,BARSLAST(HD));
       CROSS(C,前期高位);
       
       ↑前期新高
       
       C>=REF(C,1)*1.1;
       ↑↑涨停
       
       CEMA(EMA(EMA(S1,2),2),2);
       S3:=DYNAINFO(4)>0;
       
       BETWEEN(DMI.PDI,37,45)  AND S2 AND S3;
       ↗亮剑
       
       S1:="DMI.PDI";
       S2:=S1>EMA(EMA(EMA(S1,2),2),2);
       BETWEEN(DMI.PDI,45,50)  AND S2;
       
       ↗小牛
       
       S1:="DMI.PDI";
       S2:=S1>EMA(EMA(EMA(S1,2),2),2);
       
       BETWEEN(DMI.PDI,50,53)  AND S2;
       ↗大牛
       
       S1:="DMI.PDI";
       S2:=S1>EMA(EMA(EMA(S1,2),2),2);
       
       DMI.PDI>=53 AND S2;
       ↗疯牛
       
       C>=REF(C,1)*1.08;
       ↑准备打板
       
       REF(L,1)=REF(L,1)*1.05 AND C>=REF(H,1);
       $$大长腿
       
       C>=REF(C,2)*1.185;
       ¥打2板
       
       C>=REF(C,3)*1.30;
       ¥打3板
       
       三、复盘常用公式


与上面的预警公式是通用的,仅仅是侧重点不同,有重复的,但还是集中贴一下。
       
       S1:=NOT(C>=REF(C,1)*1.095 AND C=O AND H=L);
       S2:=DYNAINFO(4)>0;
       S3:=IF(NAMELIKE(‘ST‘) OR NAMELIKE(‘*ST‘),0,1);
       S4:=FINANCE(42)>1;
       H=HHV(H,0) AND S1 AND S2 AND S3  AND S4;
       //历史新高
       
       
       S1:=NOT(C>=REF(C,1)*1.0994 AND C=O AND H=L);
       A:=C/REF(C,1)>1.0994 AND S1;
       COUNT(A,2)=2;
       ++2连板(换)
       
       S2:=DYNAINFO(4)>0;{剔除停牌股}
       S4:=FINANCE(42)>1;{剔除首日上市新股}
       L=LLV(L,180) AND S2 AND S4;
       !新低
       
       
       S1:=NOT(C>=REF(C,1)*1.095 AND C=O AND H=L);{剔除一字板}
       S2:=DYNAINFO(4)>0;{剔除停牌股}
       ZT:=(CLOSE/REF(CLOSE,1)-1)*100;
       A1:=ZT>9.93 AND CLOSE=HIGH;
       XG:REF(A1,1) AND S1 AND S2;
       **昨日涨停
       
       
       ZTJ:=ZTPRICE(REF(CLOSE,1),0.1);
       CB:H=ZTJ AND C
       //冲板未封
       
       S1:=NOT(C>=REF(C,1)*1.094 AND C=O AND H=L);{剔除一字板}
       S2:=DYNAINFO(4)>0;{剔除停牌股}
       S4:=FINANCE(42)>1;{剔除首日上市新股}
       XG:L>REF(H,1) AND C/REF(C,1)>1.03 AND C/REF(C,1)0.7 AND (MIN(O,C)-L)/(H-L)>0.7;
       //揉搓线
       
       (H-MAX(C,O))/(H-L)>0.5 AND C/REF(C,1)>1.02 AND V/REF(V,1)>1.5 AND (H-L)/REF(C,1)*100>5;
       //长上引
       
       (MIN(O,C)-L)/(H-L)>0.7  AND (H-L)/REF(C,1)*100>5 ;
       //长下引



-----------------------------------------------------------

龙头战法宝贵实战经验分享系列文章




标签组:[通达信指标公式] [ema] [s1

上一篇同花顺选股,首板定妖股的指标公式,同花顺选股器怎么用

下一篇炒股公式,股票软件,股票指标,股票公式,股票

相关阅读

相同话题文章

推荐内容

热门阅读