通达信精选指标:缠论战法选股器系列,四大强势突破形态选股_源码

首页 > 教育 > 正文 2021-09-14

发表自话题:通达信缠论k线合并公式

A2:=REF(LOW,3)=LLV(LOW,笔周期*3+1);

B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);

D2:=FILTER(C2,3);

E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;

E2:=(HIGH+LOW)/2;

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

H2:=D1 AND NOT(D2 AND E1>=E2);

L1:=D2 AND NOT(D1 AND E1=E2);

X1:=REF(BARSLAST(H1),1)+1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

G1:=F1>REF(F1,1);

I1:=BACKSET(G1,2);

LD:=I1>REF(I1,1);

L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1)+1;

F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));

G2:=F2>REF(F2,1);

I2:=BACKSET(G2,2);

HD:=I2>REF(I2,1);

J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1);

J2:=J1>REF(J1,1);

A3:=H;

B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));

D3:=A3 AND B3 AND HD;

E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);

HH:=E3>REF(E3,1);

A4:=L>REF(L,REF(BARSLAST(LD),1)+1);

B4:=REF(L,REF(BARSLAST(LD),1)+1);

D4:=A4 AND B4 AND LD;

E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);

LL:=E4>REF(E4,1);

H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1;

X3:=REF(BARSLAST(H3),1)+1;

F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));

G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);

LZ:=I3>REF(I3,1);

L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;

X4:=REF(BARSLAST(L4),1)+1;

F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));

G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);

K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);

UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);

VV:=UU>REF(UU,1);

WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);

XX:=WW>REF(WW,1);

WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);

XXQ:=WWQ>REF(WWQ,1);

UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);

XX2:=WW2>REF(WW2,1);

WW3Q:=BACKSET(XX2,REF(BARSLAST(HD),1)+2);

XX3Q:=WW3Q>REF(WW3Q,1);

WW4Q:=BACKSET(XX3Q,REF(BARSLAST(HD),1)+2);

XX4Q:=WW4Q>REF(WW4Q,1);

上轨:=DRAWLINE(XX2,H,VV2,H,1);

Q4:=BARSLAST(XXQ>0);

Q5:=BARSLAST(XX3Q>0);

低一:=REF(L,BARSLAST(VV));

高一:=REF(H,BARSLAST(VV2));

低二:=REF(L,BARSLAST(XX));

高二:=REF(H,BARSLAST(XX2));

ABC:=IF(Q5>Q4,REF(L,BARSLAST(XXQ)),0);

①②③:=IF(Q5 REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);

V1:= COUNT(V00,3)>=1 AND LLVBARS(LOW,3) = 1 AND V03;

V2:= COUNT(V00,4)>=1 AND LLVBARS(LOW,4) = 2 AND V04;

V3:= COUNT(V00,4)>=1 AND COUNT(V01 OR V02,4)=1 AND LLVBARS(LOW,4) = 1 AND V03;

V4:= COUNT(V00,5)>=1 AND COUNT(V01 OR V02,5)=2 AND LLVBARS(LOW,5) = 2 AND V04;

XG1:= V1 OR V2 OR V3 OR V4;

XG2:= C > REF(HIGH,1);

XG:=XG1 AND XG2;

三买:(低一>高二 AND 近半分位>低一 AND XG>0 AND C>O);

强势突破形态选股器

源码

A1:=REF(HIGH,3)=HHV(HIGH,笔周期*3+1);

B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1);

D1:=FILTER(C1,3);

A2:=REF(LOW,3)=LLV(LOW,笔周期*3+1);

B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1);

D2:=FILTER(C2,3);

E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;

E2:=(HIGH+LOW)/2;

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

H2:=D1 AND NOT(D2 AND E1>=E2);

L1:=D2 AND NOT(D1 AND E1=E2);

X1:=REF(BARSLAST(H1),1)+1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

G1:=F1>REF(F1,1);

I1:=BACKSET(G1,2);

LD:=I1>REF(I1,1);

L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1)+1;

F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));

G2:=F2>REF(F2,1);

I2:=BACKSET(G2,2);

HD:=I2>REF(I2,1);

J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1);

J2:=J1>REF(J1,1);

A3:=H;

B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));

D3:=A3 AND B3 AND HD;

E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);

HH:=E3>REF(E3,1);

A4:=L>REF(L,REF(BARSLAST(LD),1)+1);

B4:=REF(L,REF(BARSLAST(LD),1)+1);

D4:=A4 AND B4 AND LD;

E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);

LL:=E4>REF(E4,1);

H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1;

X3:=REF(BARSLAST(H3),1)+1;

F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));

G3:=F3>REF(F3,1); I3:=BACKSET(G3,2);

LZ:=I3>REF(I3,1);

L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1;

X4:=REF(BARSLAST(L4),1)+1;

F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));

G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);

K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);

UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1);

VV:=UU>REF(UU,1);

WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);

XX:=WW>REF(WW,1);

WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2);

XXQ:=WWQ>REF(WWQ,1);

UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);

XX2:=WW2>REF(WW2,1);

WW3Q:=BACKSET(XX2,REF(BARSLAST(HD),1)+2);

XX3Q:=WW3Q>REF(WW3Q,1);

WW4Q:=BACKSET(XX3Q,REF(BARSLAST(HD),1)+2);

XX4Q:=WW4Q>REF(WW4Q,1);

上轨:=DRAWLINE(XX2,H,VV2,H,1);

Q4:=BARSLAST(XXQ>0);

Q5:=BARSLAST(XX3Q>0);

低一:=REF(L,BARSLAST(VV));

高一:=REF(H,BARSLAST(VV2));

低二:=REF(L,BARSLAST(XX));

高二:=REF(H,BARSLAST(XX2));

ABC:=IF(Q5>Q4,REF(L,BARSLAST(XXQ)),0);

强势突破:ABC>0 AND ABC

标签组:[通达信指标

上一篇各位老师:论坛上有一个.只是压缩的很厉害不能看。望各位老师看看MA1:MA(

下一篇通达信缠论分型分笔主图指标公式

相关阅读

相同话题文章

推荐内容

热门阅读