通达信缠论画中枢主图指标源码贴图

首页 > 文化 > 正文 2021-09-14

发表自话题:通达信缠论k线合并公式

本人算个指标爱好者,也喜欢学习缠论,特分享自己认为真的不错的主图指标给大家:缠论画中枢———酒香也怕巷子深


DRAWRECTREL(0,965,130,999,RGB(0,0,1)),NOFRAME;
 DRAWTEXT_FIX(1,0,1,0,''),COLOR999999;
 MA1:MA(CLOSE,M1)LINETHICK1;
 MA2:MA(CLOSE,M2)LINETHICK1;
 MA3:MA(CLOSE,M3)LINETHICK1;
 MA4:MA(CLOSE,M4)LINETHICK1;
 MA5:MA(CLOSE,M5),COLORCYAN,LINETHICK1;
 MA6:MA(CLOSE,M6)LINETHICK1;
 {下一变盘时间:TDXDLL3(205,DATE,H,L),NODRAW;}
 TIM:=TDXDLL3(100,PERIOD,H,L); {初始化周期};
KX:=TDXDLL3(1,H,L,C); {解决包含K线的问题};
VALID:=TDXDLL3(14,H,L,C);
 {DRAWICON(VALID=0,H,2); {包含测试 ,如需要去掉本最前大括号{ 符号 }
BI:=TDXDLL3(4,H,L,C); {BI类型}
KXG:=TDXDLL3(2,H,L,C); {高点}
KXD:=TDXDLL3(3,H,L,C); {低点}
BILAST:=TDXDLL3(6,H,L,C);{上一笔的距离}
 {画笔}
DRAWLINE(BI=1, KXG, BI=-1, KXD,0),COLORGREEN,DOTLINE LINETHICK2;
 DRAWLINE(BI=-1, KXD, BI=1, KXG,0),COLORMAGENTA,DOTLINE LINETHICK2;
 BILIST:=TDXDLL3(5,H,L,C);{BILIST}
 DUANLAST:=TDXDLL3(7,H,L,C);{上一段的距离}
ZS:=TDXDLL3(8,H,L,C);{中枢处理}
ZSZG:=TDXDLL3(9,H,L,C);{得到中枢ZG}
 ZSZD:=TDXDLL3(10,H,L,C);{得到中枢ZD}
 ZSKS:=TDXDLL3(11,H,L,C);{得到中枢开始}
ZSJS:=TDXDLL3(12,H,L,C);{得到中枢结束}
BIFX:=-REF(BI,BILAST);
 {画笔下跌中枢}
DRAWLINE(ZSKS=1 , ZSZG, ZSJS=1, ZSZG,0),COLORBLUE, LINETHICK1;
 DRAWLINE(ZSKS=1, ZSZD, ZSJS=1 , ZSZD,0),COLORBLUE, LINETHICK1;
 DRAWLINE(ZSKS=1 , (ZSZG+ZSZD)/2, ZSJS=1 , (ZSZG+ZSZD)/2,0),COLORYELLOW, DOTLINE;
 STICKLINE(ZSKS=1 , ZSZG, ZSZD, ZSKS=1 ,0),COLORBLUE, LINETHICK1;
 STICKLINE(ZSJS=1, ZSZG, ZSZD, ZSJS=1 ,0),COLORBLUE, LINETHICK1;
 {画笔上涨中枢}
DRAWLINE(ZSKS=2 , ZSZG, ZSJS=2, ZSZG,0),COLORRED, LINETHICK1;
 DRAWLINE(ZSKS=2, ZSZD, ZSJS=2 , ZSZD,0),COLORRED, LINETHICK1;
 DRAWLINE(ZSKS=2 , (ZSZG+ZSZD)/2, ZSJS=2 , (ZSZG+ZSZD)/2,0),COLORRED, DOTLINE;
 STICKLINE(ZSKS=2 , ZSZG, ZSZD, ZSKS=2 ,0),COLORRED, LINETHICK1;
 STICKLINE(ZSJS=2, ZSZG, ZSZD, ZSJS=2 ,0),COLORRED, LINETHICK1;
 {绘制最后当下的力度}
DRAWNUMBER(BI=1 AND N1=0,H,H-REF(L,BILAST)),COLORYELLOW;
 DRAWNUMBER(BI=-1 AND N1=0,L,L-REF(H,BILAST)),COLORGREEN;
 {绘制最后当下的力度}
DRAWNUMBER(H-REF(L,BILAST)>0 && CURRBARSCOUNT=1 AND N1=0,H,H-REF(L,BILAST)),COLORYELLOW;
 DRAWNUMBER(L-REF(H,BILAST)GG3; {缺口}
一卖A:=一卖TJ1 AND 一五段上涨 AND 一卖TJA,LINETHICK0, COLORGREEN;
一卖TJB:=DD1GG2-DD2 AND GG3-DD3-GG2-DD2;
一卖B:=一卖TJ1 AND 一五段上涨 AND 一卖TJB,LINETHICK0, COLORGREEN;

一卖TJC:=GG1>GG2 AND GG2>GG3 AND GG3>GG4 AND GG4>GG5 AND DD1>DD2 AND DD2>DD3 AND DD3>DD4 AND DD4>DD5; {连涨4段}
一卖C:=一卖TJ1 AND 一卖TJC,LINETHICK0, COLORGREEN; {27 - 68}

{二卖}
卖TJ1:=方向=-1 AND H>MA13 AND HH1DD1 AND GG1GG4 AND DD4MIN(GG3, GG4); {在下跌时有点三卖的感觉}
二卖C1:=卖TJ1 AND 二卖TJ AND 一段上涨, LINETHICK0, COLORF0F000; {41 47}

{三卖}
三卖TJ:=DD1

标签组:[通达信指标] [缠论

上一篇形象直观分笔和波段,期待高手借鉴此划线方法编制通达信能用的缠论中枢公式。

下一篇通达信好用的缠论主图指标公式

相关阅读

相同话题文章

推荐内容

热门阅读