通达信突破找顶买入(指标主图/选股源码 有未来函数 )

首页 > 文化 > 正文 2021-09-14

发表自话题:通达信缠论k线合并公式

以下是通达信突破找顶买入(指标主图/选股源码 有未来函数 )(无源码的请下载附件导入)

缠论之于股市,犹如玄学之于大学士,实在是高深莫测。苦修缠论者众矣,然股市发迹者少之又少,绝大多数还得以买书讲学度日。何故如此?避实就虚,陶醉于学问之中,不能自拔者也!把炒股作为学问来研究,应该交给学者去做。普通股民只要一招半式,几套指标,加一点盘感就够了。突破找顶主图把缠论的精确笔和分型进行技术化处理,着力点上着力,找顶线上定买点。不提缠论,却源于缠论,不提理论,只看买点和理由,便于操作。

突破找顶主图的黄虚线是趋势向上线,白虚线是趋势向下线,反应了股票的基本走势。所谓“势”,指的是趋势和走势,不是定势和必然。红线是找底线(又叫地线),是前低点的水平延长线;绿线是找顶线(又叫天线),是前高点的水平延长线。找底线和找顶线的距离是前面阶段跌幅的三分之一以下,并且当日K线突破找顶线,有成交量增量和MACD两日在零轴线上面圆滑上升的配合,出买入信号(红箭头)。

【说明】

1.指标用到未来函数,这是画线用的,不会产生漂移和数据失真现象。不喜勿喷!!!

2.指标不适应于新股和次新股,因为新股和次新股没有走出高点和低点,有的虽然有高低点,但没有得到确认。

DIF(1,100,12);

DEA(1,100,26);

MID(1,100,9);

VAR1:=CLOSE-LOW;

VAR2:=HIGH-LOW;

VAR3:=CLOSE-HIGH;

VAR4:=IF(HIGH>LOW,(VAR1/VAR2+VAR3/VAR2)*VOL,0);

HPTP:=SUM(VAR4,10)/10000,COLORSTICK;

TKXL:=(DIF-DEA)*2;

XVYO:=UPNDAY(TKXL,1);

G:=MA(C,5);D:=MA(C,10);

HH:=REF(H,5)=HHV(H,11);

LL:=REF(L,5)=LLV(L,11);

FG01:=BACKSET(HH,6)>BACKSET(HH,5);

FD01:=BACKSET(LL,6)>BACKSET(LL,5);

STICKLINE(V/REF(V,1)>2,OPEN,CLOSE,1,0),COLOR00FFFF;

FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));

FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));

FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));

FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));

GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);

DQ:=HFDZH AND FG0;

FD1:=FDLFDH AND FGL>FDL AND FGL1>FDL;

FD:=FD1 AND FDLBK);

G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))

OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));

D1:=(FD0 AND REF(L,BARSLAST(FD0))BARSLAST(D1X))

OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1)));

D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1)));

G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);

D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND LBARSLAST(D1);

NN:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));

UU:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))BARSLAST(D2));

趋势向上:DRAWLINE(UU,L,NN,H,0),COLORYELLOW,DOTLINE;

趋势向下:DRAWLINE(NN,H,UU,L,0),COLORWHITE,DOTLINE;

找顶线:DRAWLINE(NN,H,REF(NN,1),REF(H,1),1),COLORGREEN;

找底线:DRAWLINE(UU,L,REF(UU,1),REF(L,1),1),COLORRED;

DRAWNUMBER(UU,L*0.995,L);

DRAWNUMBER(NN,H*1.01,H);

XG:CROSS(C,找顶线) AND 找顶线>0 AND HPTP AND XVYO,NODRAW;

DRAWICON(XG,LOW,1);

突破找顶选股公式如下:

DIF(1,100,12);

DEA(1,100,26);

MID(1,100,9);

VAR1:=CLOSE-LOW;

VAR2:=HIGH-LOW;

VAR3:=CLOSE-HIGH;

VAR4:=IF(HIGH>LOW,(VAR1/VAR2+VAR3/VAR2)*VOL,0);

HPTP:=SUM(VAR4,10)/10000;

TKXL:=(DIF-DEA)*2;

XVYO:=UPNDAY(TKXL,1);

G:=MA(C,5);D:=MA(C,10);

HH:=REF(H,5)=HHV(H,11);

LL:=REF(L,5)=LLV(L,11);

FG01:=BACKSET(HH,6)>BACKSET(HH,5);

FD01:=BACKSET(LL,6)>BACKSET(LL,5);

FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));

FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));

FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));

FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));

GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);

DQ:=HFDZH AND FG0;

FD1:=FDLFDH AND FGL>FDL AND FGL1>FDL;

FD:=FD1 AND FDLBK);

G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))

OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));

D1:=(FD0 AND REF(L,BARSLAST(FD0))BARSLAST(D1X))

OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1)));

D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1)));

G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);

D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND LBARSLAST(D1);

G3:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));

找顶线:=DRAWLINE(G3,H,REF(G3,1),REF(H,1),1);

XG:CROSS(C,找顶线) AND 找顶线>0 AND HPTP AND XVYO;

标签组:[选股] [通达信指标] [通达信选股公式

上一篇自己所有的指标,看趋势操作,引力传媒,,绿庭投资,黑芝麻是今年按指标操作的票

下一篇如题:请老师帮编写一个通达信的成交量和持仓量叠加在一起的公式,拜托了!

相关阅读

相同话题文章

推荐内容

热门阅读