通达信主窗口显示股票所属板块及概念语句

首页 > 财经 > 正文 2021-09-14

发表自话题:通达信分时图显示概念板块

一、通达信函数:

自选股:\T0002\blocknew文件夹下的文件复制到新版本相同目录下。

策略股票池:\T0002\tpool文件夹为策略股票池,复制到新版本相同目录下。

公司:\T0002文件夹下的PriCS.dat,PriGS.dat,PriText.dat 文件是公式相关数据

HYBLOCK 是行业板块,DYBLOCK是地域板块,GNBLOCK是概念板块,ZDBLOCK是自定义板块。

STRCAT(A,B):将两个字符串A,B(非序列化)相加成一个字符串C。用法:
STRCAT('多头','开仓')将两个字符串'多头','开仓'相加成一个字符串'多头开仓'

二、通达信主图显示板块信息

可以将以上语句写入MA等主图指标。

方式一:

MA1:MA(CLOSE,M1);MA2:MA(CLOSE,M2);MA3:MA(CLOSE,M3);MA4:MA(CLOSE,M4),LINETHICK2,colorgreen;MA5:MA(CLOSE,M5),LINETHICK2;{通达信文字指标}SBL:= STRCAT(STRCAT(STRCAT(HYBLOCK,DYBLOCK),GNBLOCK),ZDBLOCK);DRAWTEXT_FIX(1,0,0,0,SBL),COLORFF6000;

方式二:

MA1:MA(CLOSE,M1);MA2:MA(CLOSE,M2);MA3:MA(CLOSE,M3);MA4:MA(CLOSE,M4),LINETHICK2;MA5:MA(CLOSE,M5),LINETHICK2;{通达信文字指标}A1:=STRCAT(STRCAT('总收入同比增长:',CON2STR(FINANCE(44),2)),'% ');A2:=STRCAT(A1,STRCAT(STRCAT('净利润同比增长:',CON2STR(FINANCE(43),2)),'% '));A3:=STRCAT(A2,STRCAT(STRCAT('资产负债率:',CON2STR(FINANCE(9),2)),'% '));A4:=STRCAT(A3,STRCAT(STRCAT('每股现金流:',CON2STR(FINANCE(25)/FINANCE(1),2)),'元'));DRAWTEXT_FIX(ISLASTBAR,0.001,0.00,0,STRCAT(A4,0)),COLORyellow ; B1:=STRCAT(DYBLOCK,' ');B2:=STRCAT(B1,STRCAT(HYBLOCK,' '));B3:=STRCAT(B2,STRCAT(FGBLOCK,' '));B4:=STRCAT(B3,STRCAT(GNBLOCK,' '));DRAWTEXT_FIX(ISLASTBAR,0.001,0.06,0,STRCAT(B4,0)),COLORWHITE ;

三、热点专题

1、中信建投通达信卓越版——选股——热点专题,当前热点概念及包股票。

2、通达信金融终端版

市场——主题投资——主题库

 

 

专题——行业数据

 

资讯——自选咨询

概念——概念库——相关个股——关联主题。

标签组:[股票] [通达信公式] [strcat

上一篇通达信分时图上显示题材概念,通达信定制选股

下一篇通达信在分时图显示题材概念,分时图指标公式

相关阅读

相同话题文章

推荐内容

热门阅读